Skip to main content

SongPop 2

Comments

1 comment

  • Larryfd24

    At least you still have Songpop2. My Kindle, where I have used Songpop2 since its inception years ago, now tells me that my Songpop2 is "outdated" ( which of course, it isn't), and only let's my play by using Songpop1  - which IS outdated and is a huge step backwards.

    0

Please sign in to leave a comment.

Powered by Zendesk