Comments

4 comments

  • Stuart Hilliard

    The latest version of Song Pop 2 requires iOS 10 or higher.

    0
    Comment actions Permalink
  • Agall1013

    I use song pop 1 and I have 12 iOS

    0
    Comment actions Permalink
  • Stuart Hilliard

    iOS 12 does not support Song Pop 1. Try Song Pop 2 you will love it!

    0
    Comment actions Permalink
  • Agall1013

    Thanks a lot. It migrated the people I’ve been playing with for years.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Powered by Zendesk